1. XenForo 1.5.14 中文版——支持中文搜索!现已发布!查看详情
  2. Xenforo 爱好者讨论群:215909318 XenForo专区

RouterOS笔记

本帖由 admin2019-02-05 发布。版面名称:应用交流

  1. admin

    admin 管理员 管理成员

    注册:
    2011-11-01
    帖子:
    3,665
    赞:
    2,421
    RouterOS利用DNSPOD的API接口实现DDNS动态解析
    代码:
    :global ipnew [/ip address get [/ip address find interface=(拨号接口)] address]
    :set ipnew [:pick $ipnew 0 ([len $ipnew] -3)]
    :global ipold
    :if (($ipnew != "") && ($ipnew != $ipold)) do={
    /tool fetch url=("http://域名/dnspod.php\?id=(ID)&token=(TOKEN)&ip=$ipnew&domain=(域名)&sub_domain=(子域名)") mode=http keep-result=no
    :set ipold $ipnew
    log info "DDNS: Sending UPDATE!"
    }
    参考文献:
    dnspod-api-php:https://github.com/myxzy/dnspod-api-php/
     
正在加载...